CVE-2026-44166

Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade

HIGH
7.6
CVSS Score
Published: May 12, 2026 at 05:16 PM UTC
Updated: June 17, 2026 at 10:50 AM UTC
1 product affected across 1 vendorPocketBase

Using pocketbase by pocketbase?

Get instant alerts when new vulnerabilities affect pocketbase - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.6
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.22.42v < 0.37.40.23.0 ≤ v < 0.37.4
Affected range stops below 0.22.42, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.37.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
HIGH
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card