CVE-2026-44028

HIGH
7.5
CVSS Score
Published: May 5, 2026 at 12:30 AM UTC
Updated: October 26, 2026 at 07:10 PM UTC
2 products affected across 2 vendorsNixLix

Using Nix by NixOS?

Get instant alerts when new vulnerabilities affect Nix - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

An issue was discovered in Nix before 2.34.7 and Lix before 2.95.2. Unbounded recursion in the NAR (Nix Archive) parser could lead to a stack-to-heap overflow when the parser is run on a coroutine stack. The stack is allocated without a guard page, which means that a stack overflow could overwrite memory on the heap and could allow arbitrary code execution as the Nix daemon (run as root in multi-user installations) if ASLR hardening is bypassed. This can be exploited by all users able to connect to the daemon (e.g., in Nix, this is configurable via the allowed-users setting, defaulting to all users). The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 for Nix (introduced in 2.24.4); and 2.95.2, 2.94.2, and 2.93.4 for Lix (introduced in 2.93.0).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.93.0 ≤ v < 2.93.42.94.0 ≤ v < 2.94.22.95.0 ≤ v < 2.95.22.93.02.94.02.95.0
Affected range stops below 2.93.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.94.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.95.2, so it looks safe — our inference, not a vendor statement
2.24.4 ≤ v < 2.28.72.29.0 ≤ v < 2.29.42.30.0 ≤ v < 2.30.52.31.0 ≤ v < 2.31.52.32.0 ≤ v < 2.32.82.33.0 ≤ v < 2.33.62.34.0 ≤ v < 2.34.72.24.42.29.02.30.02.31.02.32.02.33.02.34.0
Affected range stops below 2.28.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.29.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.30.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.31.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.32.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.33.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.34.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHmitre
Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-674

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card