CVE-2026-4296

Incorrect Regular Expression vulnerability in GitHub Enterprise Server allowed unauthorized access to user accounts via OAuth callback URL validation bypass

HIGH
8.8
CVSS Score
Published: April 21, 2026 at 10:12 PM UTC
Updated: October 26, 2026 at 10:10 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

An incorrect regular expression vulnerability was identified in GitHub Enterprise Server that allowed an attacker to bypass OAuth redirect URI validation. An attacker with knowledge of a first-party OAuth application's registered callback URL could craft a malicious authorization link that, when clicked by a victim, would redirect the OAuth authorization code to an attacker-controlled domain. This could allow the attacker to gain unauthorized access to the victim's account with the scopes granted to the OAuth application. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.1, 3.19.5, 3.18.8, 3.17.14, 3.16.17, 3.15.21, 3.14.26. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.14.263.15.0 ≤ v < 3.15.213.16.0 ≤ v < 3.16.173.17.0 ≤ v < 3.17.143.18.0 ≤ v < 3.18.83.19.0 ≤ v < 3.19.53.14.03.15.03.16.03.17.03.18.03.19.03.20.0
Affected range stops below 3.20.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-185

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card