CVE-2026-42945

NGINX ngx_http_rewrite_module vulnerability

HIGH
8.1
CVSS Score
Published: May 13, 2026 at 02:12 PM UTC
Updated: September 10, 2026 at 01:20 PM UTC
8 products affected across 2 vendorsNGINX PlusNGINX Open SourceNGINX Ingress Controller

Using NGINX Plus by F5?

Get instant alerts when new vulnerabilities affect NGINX Plus - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 68%
SSVC
No known exploit

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when the rewrite directive is followed by a rewrite, if, or set directive and an unnamed Perl-Compatible Regular Expression (PCRE) capture (for example, $1, $2) with a replacement string that includes a question mark (?). An unauthenticated attacker along with conditions beyond its control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, for systems with Address Space Layout Randomization (ASLR ) disabled, code execution is possible.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.3.0 ≤ v ≤ 4.7.04.8.0
1.3.0 ≤ v ≤ 1.6.22.0.0 ≤ v ≤ 2.5.1
3.5.0 ≤ v ≤ 3.7.24.0.0 ≤ v ≤ 4.0.15.0.0 ≤ v ≤ 5.4.1
2.16.0 ≤ v ≤ 2.21.1
0.6.27 ≤ v ≤ 1.30.00.6.27 ≤ v < 1.30.10.6.27
Affected range stops below 1.30.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.31.0 (unaffected)
R32 ≤ v < R32 P6R36 ≤ v < R36 P4r32 ≤ v ≤ r36R32R36
Affected range stops below R32 P6, so it looks safe — our inference, not a vendor statement
Affected range stops below R36 P4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in R37 (unaffected)
4.9.0 ≤ v ≤ 4.16.05.1.0 ≤ v ≤ 5.8.05.9.0 ≤ v ≤ 5.12.1

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (34)

Vendor AdvisoryPatchMitigation
Source: cverecord
https://my.f5.com/manage/s/article/K000161019
MitigationTechnical DescriptionThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://depthfirst.com/nginx-rift
ExploitThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
https://github.com/DepthFirstDisclosures/Nginx-Rift
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17417
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17751
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17752
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17753
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17790

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.1HIGHf5
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-122CWE-131

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card