CVE-2026-42789

Non-CA certificate accepted as intermediate issuer in public_key path validation

MEDIUM
4.8
CVSS Score
Published: May 27, 2026 at 12:23 PM UTC
Updated: October 26, 2026 at 11:10 AM UTC
3 products affected across 2 vendorsErlang /otpOpenStack PlatformHardened Images

Using OTP by Erlang?

Get instant alerts when new vulnerabilities affect OTP - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Improper Following of a Certificate's Chain of Trust vulnerability in Erlang OTP public_key (pubkey_cert module) allows a non-CA certificate to be accepted as an intermediate issuer, enabling certificate chain forgery. In lib/public_key/src/pubkey_cert.erl, pubkey_cert:validate_extensions/7 contains two flaws that together allow a certificate with basicConstraints cA:false and no keyUsage extension to be used as an intermediate issuer in a chain passed to public_key:pkix_path_validation/3: the cA:false clause recurses into the remaining extensions without rejecting the certificate when it is in issuer position, and the keyUsage check only fires when the extension is present, so a certificate lacking keyUsage entirely bypasses the keyCertSign enforcement. Any party holding an end-entity certificate with basicConstraints cA:false and no keyUsage extension, issued by any CA in the victim's trust store, can use that certificate's private key to sign forged leaf certificates for arbitrary identities. public_key:pkix_path_validation/3 accepts the resulting chain, and by extension every TLS or mTLS endpoint built on the OTP ssl application that relies on the default verifier is affected, including server identity verification on the client side and client certificate verification on mTLS servers. This issue affects OTP from OTP 17.0 before OTP 26.2.5.21, 27.3.4.12, 28.5.0.1, and 29.0.1 corresponding to public_key from 0.22 before 1.15.1.7, 1.17.1.3, 1.20.3.1, and 1.21.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

17.0 ≤ v < 26.2.5.2127.0 ≤ v < 27.3.4.1228.0 ≤ v < 28.5.0.129.0 ≤ v < 29.0.10.2217.084adefa331c4159d432d22840663c38f155cd4c1
Vendor states this is fixed in 0a05b7ca33fb0b3f0a6cb9ae34252bb3a74032b8 (unaffected)
Affected range stops below 26.2.5.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 27.3.4.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 28.5.0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 29.0.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 471cd2f664300a95353c467873800bbe706005db (unaffected)
Vendor states this is fixed in 59c8d824386b2eb1614ff9340624843ef6aca0fd (unaffected)
Vendor states this is fixed in 75ca4c0dc2bbdb286ac3c3fe89cb4b4d2b4dc333 (unaffected)
Vendor states this is fixed in 82af606b5437c4de1276dbcc8855a47e88231226 (unaffected)
All versions
Vendor states this is fixed in 0:23.3.4.18-2.el8ost (unaffected)

References (14)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-295CWE-296

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card