CVE-2026-42587

Netty: HttpContentDecompressor maxAllocation bypass via Content-Encoding: br/zstd/snappy enables decompression bomb DoS

HIGH
7.5
CVSS Score
Published: May 13, 2026 at 06:22 PM UTC
Updated: October 26, 2026 at 05:10 PM UTC
15 products affected across 3 vendorsNettynetty-codec-http2Netty

Using netty by netty?

Get instant alerts when new vulnerabilities affect netty - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1.0%
SSVC
PoC

Description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, HttpContentDecompressor accepts a maxAllocation parameter to limit decompression buffer size and prevent decompression bomb attacks. This limit is correctly enforced for gzip and deflate encodings via ZlibDecoder, but is silently ignored when the content encoding is br (Brotli), zstd, or snappy. An attacker can bypass the configured decompression limit by sending a compressed payload with Content-Encoding: br instead of Content-Encoding: gzip, causing unbounded memory allocation and out-of-memory denial of service. The same vulnerability exists in DelegatingDecompressorFrameListener for HTTP/2 connections. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.1.1334.2.0 ≤ v < 4.2.13
Affected range stops below 4.1.133, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.133.Final, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.13.Final, so it looks safe — our inference, not a vendor statement
v < 4.1.133.Final4.2.0.Alpha1 ≤ v < 4.2.13.Final
Affected range stops below 4.1.133.Final, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.13.Final, so it looks safe — our inference, not a vendor statement
All versions
60%
Vendor states this is fixed in 4.2.0-10 (unaffected)
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (24)

x_refsource_CONFIRMExploitMitigationVendor Advisory
Source: cverecord
https://github.com/netty/netty/security/advisories/GHSA-f6hv-jmp6-3vwv
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:23808
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:24502
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:25123
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:28010
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-42587
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2477220

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card