CVE-2026-42426

OpenClaw < 2026.4.8 - Improper Authorization in node.pair.approve via operator.write Scope

HIGH
8.8
CVSS Score
Published: April 28, 2026 at 06:10 PM UTC
Updated: June 17, 2026 at 10:47 AM UTC
1 product affected across 1 vendorOpenClaw

Using OpenClaw by OpenClaw?

Get instant alerts when new vulnerabilities affect OpenClaw - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

OpenClaw before 2026.4.8 contains an improper authorization vulnerability where the node.pair.approve method accepts operator.write scope instead of the narrower operator.pairing scope, allowing unprivileged users to approve node pairing. Attackers with operator.write permissions can bypass pairing approval restrictions to gain unauthorized access to exec-capable nodes.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2026.4.8
Vendor states this is fixed in 2026.4.8 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card