CVE-2026-42349

Clerk: Authorization bypass when combining organization, billing, or reverification checks

HIGH
8.1
CVSS Score
Published: May 11, 2026 at 04:08 PM UTC
Updated: October 26, 2026 at 06:10 PM UTC
18 products affected across 1 vendorClerk /astroClerk /sharedClerk /nextjs

Using javascript by clerk?

Get instant alerts when new vulnerabilities affect javascript - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 0.2%
SSVC
PoC

Description

Clerk JavaScript is the official JavaScript repository for Clerk authentication. has(), auth.protect(), and related authorization predicates in @clerk/shared, @clerk/nextjs, @clerk/backend, and other framework SDKs can return true for certain combined authorization checks when the result should be false, allowing a gated action to proceed for a user who does not satisfy the full set of requested conditions. This call shape can be bypassed if certain conditions are met: a has() or auth.protect() call that combines a reverification check with any of role, permission, feature, or plan, or that combines a billing check (feature or plan) with a role or permission check. This vulnerability is fixed in @clerk/clerk-js 5.125.10 and 6.7.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.0.0 ≤ v < 2.17.113.0.0 ≤ v < 3.0.18
Affected range stops below 2.17.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.0.18, so it looks safe — our inference, not a vendor statement
2.0.0 ≤ v < 2.33.33.0.0 ≤ v < 3.2.14
Affected range stops below 2.33.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.14, so it looks safe — our inference, not a vendor statement
1.3.5 ≤ v < 2.9.153.0.0 ≤ v < 3.1.15
Affected range stops below 2.9.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.15, so it looks safe — our inference, not a vendor statement
2.2.11 ≤ v < 2.19.36
Affected range stops below 2.19.36, so it looks safe — our inference, not a vendor statement
5.22.0 ≤ v < 5.125.106.0.0 ≤ v < 6.7.5
Affected range stops below 5.125.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7.5, so it looks safe — our inference, not a vendor statement
5.9.0 ≤ v < 5.61.6
Affected range stops below 5.61.6, so it looks safe — our inference, not a vendor statement
3.0.0 ≤ v < 3.2.2
Affected range stops below 3.2.2, so it looks safe — our inference, not a vendor statement
0.1.0 ≤ v < 1.7.792.0.0 ≤ v < 2.1.6
Affected range stops below 1.7.79, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.6, so it looks safe — our inference, not a vendor statement
1.0.42 ≤ v < 2.6.313.0.0 ≤ v < 3.1.16
Affected range stops below 2.6.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.16, so it looks safe — our inference, not a vendor statement
0.0.2 ≤ v < 0.1.16
Affected range stops below 0.1.16, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMMitigationVendor Advisory
Source: cverecord
https://github.com/clerk/javascript/security/advisories/GHSA-w24r-5266-9c3c

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-754CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card