CVE-2026-42307

Vim: OS Command Injection in netrw

MEDIUM
4.4
CVSS Score
Published: May 8, 2026 at 10:38 PM UTC
Updated: July 24, 2026 at 09:20 PM UTC
1 product affected across 1 vendorVim

Using vim by vim?

Get instant alerts when new vulnerabilities affect vim - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.4
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

Vim is an open source, command line text editor. Prior to version 9.2.0383, an OS command injection vulnerability exists in the netrw standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the sftp:// or file:// protocol handlers), an attacker can execute arbitrary shell commands with the privileges of the Vim process. This issue has been patched in version 9.2.0383.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 9.2.0383
Affected range stops below 9.2.0383, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMPatchVendor Advisory
Source: cverecord
https://github.com/vim/vim/security/advisories/GHSA-85ch-p2qr-m5gx
x_refsource_MISCProduct
Source: cverecord
https://github.com/vim/vim/releases/tag/v9.2.0383

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.4MEDIUMGitHub_M
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card