CVE-2026-42271

LiteLLM: Authenticated command execution via MCP stdio test endpoints

HIGH
8.8
CVSS Score
Published: May 8, 2026 at 03:35 AM UTC
Updated: October 26, 2026 at 08:10 PM UTC
3 products affected across 3 vendorsOpenShift AILiteLLMLiteLLM

Using litellm by BerriAI?

Get instant alerts when new vulnerabilities affect litellm - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 91%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score91.4%

EPSS (Exploit Prediction Scoring System) estimates a 91.4% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

BerriAI LiteLLM contains a command injection vulnerability that could allow any authenticated user, including holders of low-privilege internal-user keys, to run arbitrary commands on the host.

Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Jun 8, 2026
Remediation Due
Jun 22, 2026
129 days overdue

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.74.2 ≤ v < 1.83.7
Affected range stops below 1.83.7, so it looks safe — our inference, not a vendor statement
2.25 ≤ v < 2.25.83.3 ≤ v < 3.3.43.4
Vendor states this is fixed in 1781622627 (unaffected)
Vendor states this is fixed in 1781826406 (unaffected)
Vendor states this is fixed in 1782310008 (unaffected)
Affected range stops below 2.25.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.4, so it looks safe — our inference, not a vendor statement
1.74.2 ≤ v < 1.83.7
Affected range stops below 1.83.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (9)

x_refsource_CONFIRMMitigationPatchVendor Advisory
Source: cverecord
https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
US Government Resource
Source: 134c704f-9b21-4f2e-91b3-4a467353bcc0
https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42271
Third Party Advisory
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:27784
Third Party Advisory
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:28960
Third Party Advisory
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:30056
Third Party Advisory
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-42271
Third Party Advisory
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2467924

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHredhat-SADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-77CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card