CVE-2026-41887

Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

MEDIUM
4.9
CVSS Score
Published: May 8, 2026 at 03:50 PM UTC
Updated: October 26, 2026 at 06:10 PM UTC
1 product affected across 1 vendorFlarum

Using framework by flarum?

Get instant alerts when new vulnerabilities affect framework - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.9
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

90%
v < 1.8.162.0.0-beta.1 ≤ v < 2.0.0-rc.12.0.0-beta.1
Affected range stops below 1.8.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.0-rc.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.9MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-22CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card