CVE-2026-41423

Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server

MEDIUM
5.3
CVSS Score
Published: May 8, 2026 at 01:06 PM UTC
Updated: June 17, 2026 at 10:46 AM UTC
1 product affected across 1 vendor@angular

Using angular by angular?

Get instant alerts when new vulnerabilities affect angular - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server due to improper handling of URLs during Server-Side Rendering (SSR). When an attacker sends a request such as GET /\evil.com/ HTTP/1.1 the server engine (Express, etc.) passes the URL string to Angular’s rendering functions. Because the URL parser normalizes the backslash to a forward slash for HTTP/HTTPS schemes, the internal state of the application is hijacked to believe the current origin is evil.com. This misinterpretation tricks the application into treating the attacker’s domain as the local origin. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This issue has been patched in versions 19.2.21, 20.3.19, 21.2.9, and 22.0.0-next.8.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 19.2.21v < 20.3.19v < 21.2.9v < 22.0.0-next.820.0.0 ≤ v < 20.3.1921.0.0 ≤ v < 21.2.922.0.0 next022.0.0 next122.0.0 next222.0.0 next322.0.0 next422.0.0 next522.0.0 next622.0.0 next722.0.0 next8
Affected range stops below 19.2.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.0.0-next.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMMitigationVendor Advisory
Source: cverecord
https://github.com/angular/angular/security/advisories/GHSA-45q2-gjvg-7973
x_refsource_MISCIssue Tracking
Source: cverecord
https://github.com/angular/angular/pull/68194

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card