CVE-2026-41325

Kirby is vulnerable to authorization bypass during page, file and user creation via blueprint injection

HIGH
8.8
CVSS Score
Published: April 24, 2026 at 12:38 AM UTC
Updated: October 26, 2026 at 10:10 PM UTC
1 product affected across 1 vendorKirby

Using kirby by getkirby?

Get instant alerts when new vulnerabilities affect kirby - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Kirby is an open-source content management system. Kirby's user permissions control which user role is allowed to perform specific actions to content models in the CMS. These permissions are defined for each role in the user blueprint (`site/blueprints/users/...`). It is also possible to customize the permissions for each target model in the model blueprints (such as in `site/blueprints/pages/...`) using the `options` feature. The permissions and options together control the authorization of user actions. Kirby provides the `pages.create`, `files.create` and `users.create` permissions (among others). These permissions can again be set in the user blueprint and/or in the blueprint of the target model via `options`. Prior to versions 4.9.0 and 5.4.0, Kirby allowed to override the `options` during the creation of pages, files and users by injecting custom dynamic blueprint configuration into the model data. The injected `options` could include `'create' => true`, which then caused an override of the permissions and options configured by the site developer in the user and model blueprints. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. The patched versions have updated the normalization code that is used during the creation of pages, files and users to include a filter for the `blueprint` property. This prevents the injection of dynamic blueprint configuration into the creation request.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 4.9.05.0.0 ≤ v < 5.4.0
Affected range stops below 4.9.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMPatchVendor Advisory
Source: cverecord
https://github.com/getkirby/kirby/security/advisories/GHSA-6gqr-mx34-wh8r
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/getkirby/kirby/releases/tag/4.9.0
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/getkirby/kirby/releases/tag/5.4.0

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card