CVE-2026-41044

Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All: Authenticated user can perform RCE via DestinationView MBean exposed by Jolokia

HIGH
8.8
CVSS Score
Published: April 24, 2026 at 10:16 AM UTC
Updated: July 15, 2026 at 02:21 AM UTC
4 products affected across 2 vendorsActiveMQApache ActiveMQ BrokerJBoss Enterprise Application Platform

Using Apache ActiveMQ by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache ActiveMQ - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 1.0%
SSVC
No known exploit

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All. An authenticated attacker can use the admin web console page to construct a malicious broker name that bypasses name validation to include an xbean binding that can be later used by a VM transport to load a remote Spring XML application. The attacker can then use the DestinationView mbean to send a message to trigger a VM transport creation that will reference this malicious broker name which can lead to loading the malicious Spring XML context file. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.19.66.0.0 ≤ v < 6.2.56.0.0
Affected range stops below 5.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.5, so it looks safe — our inference, not a vendor statement
v < 5.19.66.0.0 ≤ v < 6.2.56.0.0
Affected range stops below 5.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.5, so it looks safe — our inference, not a vendor statement
v < 5.19.66.0.0 ≤ v < 6.2.56.0.0
Affected range stops below 5.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/04/23/6
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-41044
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2461409

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card