CVE-2026-4103

Cross-Site Scripting via HTML Sanitization in WSO2 Publisher and Developer Portals Allows Malicious Script Execution

MEDIUM
6.4
CVSS Score
Published: September 14, 2026 at 03:54 PM UTC
Updated: September 18, 2026 at 07:29 PM UTC
2 products affected across 1 vendorAPI ManagerAPI Control Plane

Using WSO2 API Control Plane by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 API Control Plane - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.4
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Insufficient HTML sanitization in the Publisher Portal and Developer Portal allows untrusted user input to be rendered without proper encoding or neutralization. This enables the injection and execution of malicious JavaScript when affected API documents are viewed. Successful exploitation may result in the execution of malicious scripts within the user's browser context when viewing API documentation. Users with permissions to access the API documentation through these portals may be impacted, potentially allowing attackers to perform actions on behalf of the user, depending on their session privileges.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.554.6.0 ≤ v < 4.6.0.194.5.04.6.0
Affected range stops below 4.5.0.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.19, so it looks safe — our inference, not a vendor statement
3.2.0 ≤ v < 3.2.0.4703.2.1 ≤ v < 3.2.1.894.1.0 ≤ v < 4.1.0.2544.2.0 ≤ v < 4.2.0.1944.3.0 ≤ v < 4.3.0.1054.4.0 ≤ v < 4.4.0.694.5.0 ≤ v < 4.5.0.544.6.0 ≤ v < 4.6.0.183.2.03.2.14.1.04.2.04.3.04.4.04.5.04.6.0
Affected range stops below 3.2.0.470, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.89, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.254, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.194, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.105, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.69, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.54, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.18, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.2.0 (unknown)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.4MEDIUMWSO2
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card