CVE-2026-40984

Micrometer HTTP server instrumentations DoS vulnerability

HIGH
7.5
CVSS Score
Published: June 9, 2026 at 03:47 AM UTC
Updated: September 14, 2026 at 01:18 PM UTC
10 products affected across 2 vendorsJBoss Enterprise Application Platform Expansion PackBuild of Apicurio RegistryProcess Automation

Using Micrometer by Spring?

Get instant alerts when new vulnerabilities affect Micrometer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

In Micrometer, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Affected versions: micrometer-core 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18; 1.9.0 through 1.9.17. micrometer-jetty11 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18. micrometer-jetty12 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions
Vendor states this is fixed in 3.2.1 (unaffected)
1.13.0 ≤ v < 1.13.191.14.0 ≤ v < 1.14.15.11.14.0 ≤ v < 1.14.161.15.0 ≤ v < 1.15.11.1.15.0 ≤ v < 1.15.11.11.16.0 ≤ v < 1.16.5.11.16.0 ≤ v < 1.16.61.9.0 ≤ v < 1.9.181.13.01.14.01.15.01.16.01.9.0
Affected range stops below 1.13.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.14.15.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.14.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.11., so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.11.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.16.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.16.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.18, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (13)

Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-40984
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2486716
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:36839
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:37390
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:41951
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:50848

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHvmware
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-400CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card