CVE-2026-40944

Oxia: TLS CA certificate chain validation fails with multi-certificate PEM bundles

MEDIUM
6.9
CVSS Score
Published: April 21, 2026 at 09:14 PM UTC
Updated: June 17, 2026 at 10:45 AM UTC
1 product affected across 1 vendorOxia

Using oxia by oxia-db?

Get instant alerts when new vulnerabilities affect oxia - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.9
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Oxia is a metadata store and coordination system. Prior to 0.16.2, the trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. This vulnerability is fixed in 0.16.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.16.2
Affected range stops below 0.16.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (1)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.9MEDIUMGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-295

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card