CVE-2026-40938

Tekton Pipelines: Git Resolver Unsanitized Revision Parameter Enables git Argument Injection Leading to RCE

HIGH
8.5
CVSS Score
Published: April 21, 2026 at 08:45 PM UTC
Updated: October 26, 2026 at 09:10 PM UTC
3 products affected across 3 vendorsTekton PipelinesPipelineOpenShift Pipelines

Using pipeline by tektoncd?

Get instant alerts when new vulnerabilities affect pipeline - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.5
Exploit prediction
EPSS 0.8%
SSVC
PoC

Description

Tekton Pipelines project provides k8s-style resources for declaring CI/CD-style pipelines. From 1.0.0 to before 1.11.0, the git resolver's revision parameter is passed directly as a positional argument to git fetch without any validation that it does not begin with a - character. Because git parses flags from mixed positional arguments, an attacker can inject arbitrary git fetch flags such as --upload-pack=<binary>. Combined with the validateRepoURL function explicitly permitting URLs that begin with / (local filesystem paths), a tenant who can submit ResolutionRequest objects can chain these two behaviors to execute an arbitrary binary on the resolver pod. The tekton-pipelines-resolvers ServiceAccount holds cluster-wide get/list/watch on all Secrets, so code execution on the resolver pod enables full cluster-wide secret exfiltration. This vulnerability is fixed in 1.11.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.0.0 ≤ v < 1.11.0
Affected range stops below 1.11.0, so it looks safe — our inference, not a vendor statement
1.0.0 ≤ v < 1.0.21.10.0 ≤ v < 1.11.11.2.0 ≤ v < 1.3.41.4.0 ≤ v < 1.6.21.7.0 ≤ v < 1.9.3
Affected range stops below 1.0.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.11.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.3.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.6.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.3, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 1780645012 (unaffected)
Vendor states this is fixed in 1781686494 (unaffected)
Vendor states this is fixed in cli-1.21.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (10)

x_refsource_CONFIRMExploitVendor Advisory
Source: cverecord
https://github.com/tektoncd/pipeline/security/advisories/GHSA-94jr-7pqp-xhcq
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/tektoncd/pipeline/releases/tag/v1.11.1
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17546
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:24359
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:24484
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:26519
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:26538
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-40938

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.5HIGHredhat-SADP
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-88

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card