CVE-2026-40701

NGINX ngx_http_ssl_module vulnerability

MEDIUM
4.8
CVSS Score
Published: May 13, 2026 at 02:12 PM UTC
Updated: June 23, 2026 at 05:34 PM UTC
7 products affected across 1 vendorNGINX PlusNGINX Open SourceNGINX Ingress Controller

Using NGINX Plus by F5?

Get instant alerts when new vulnerabilities affect NGINX Plus - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssl_module module when the ssl_verify_client directive is set to "on" or "optional," and the ssl_ocsp directive is set to "on" or the leaf parameters are configured with a resolver. With this configuration, an unauthenticated attacker can send requests along with conditions beyond its control that may cause a heap-use-after-free error in the NGINX worker process. This vulnerability may result in limited modification of data or the NGINX worker process restarting. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.3.0 ≤ v ≤ 4.7.04.8.0
1.3.0 ≤ v ≤ 1.6.22.0.0 ≤ v ≤ 2.6.0
3.5.0 ≤ v ≤ 3.7.24.0.0 ≤ v ≤ 4.0.15.0.0 ≤ v ≤ 5.4.2
2.16.0 ≤ v ≤ 2.22.0
1.19.0 ≤ v ≤ 1.30.01.19.0 ≤ v < 1.30.11.19.0
Affected range stops below 1.30.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 1.31.0 (unaffected)
R32 ≤ v < R32 P6R36 ≤ v < R36 P4r32 ≤ v ≤ r36R32R36
Affected range stops below R32 P6, so it looks safe — our inference, not a vendor statement
Affected range stops below R36 P4, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in R37 (unaffected)
4.9.0 ≤ v ≤ 4.16.05.1.0 ≤ v ≤ 5.8.05.9.0 ≤ v ≤ 5.12.1

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

Vendor AdvisoryPatchMitigation
Source: cverecord
https://my.f5.com/manage/s/article/K000161021

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.8MEDIUMf5
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-416

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card