CVE-2026-40466

Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Possible bypass of CVE-2026-34197 via HTTP discovery second-stage URI

HIGH
8.8
CVSS Score
Published: April 24, 2026 at 10:15 AM UTC
Updated: July 15, 2026 at 02:21 AM UTC
4 products affected across 2 vendorsActiveMQApache ActiveMQ BrokerJBoss Enterprise Application Platform

Using Apache ActiveMQ Broker by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache ActiveMQ Broker - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 5%
SSVC
No known exploit

Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ. An authenticated attacker may bypass the fix in CVE-2026-34197 by adding a connector using an HTTP Discovery transport via BrokerView.addNetworkConnector or BrokerView.addConnector through Jolokia if the activemq-http module is on the classpath. A malicious HTTP endpoint can return a VM transport through the HTTP URI which will bypass the validation added in CVE-2026-34197. The attacker can then use the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 5.19.6 or 6.2.5, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.19.66.0.0 ≤ v < 6.2.56.0.0
Affected range stops below 5.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.5, so it looks safe — our inference, not a vendor statement
v < 5.19.66.0.0 ≤ v < 6.2.56.0.0
Affected range stops below 5.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.5, so it looks safe — our inference, not a vendor statement
v < 5.19.66.0.0 ≤ v < 6.2.56.0.0
Affected range stops below 5.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-40466
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2461410

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card