CVE-2026-39852

Quarkus authorization bypass via semicolon path normalization inconsistency

HIGH
8.2
CVSS Score
Published: May 5, 2026 at 08:58 PM UTC
Updated: August 17, 2026 at 12:18 PM UTC
10 products affected across 3 vendorsQuarkusOpenShift AIJBoss Enterprise Application Platform Expansion Pack

Using quarkus by quarkusio?

Get instant alerts when new vulnerabilities affect quarkus - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.2
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Quarkus is a Java framework for building cloud-native applications. In versions prior to 3.20.6.1, 3.27.3.1, 3.33.1.1, 3.35.1.1, 3.34.7, and 3.35.2, a path normalization inconsistency between the security layer and the routing layer allows unauthenticated or lower-privileged users to bypass HTTP path-based authorization policies. Quarkus's security layer performs authorization checks on the raw URL path which preserves matrix parameters (semicolons), while RESTEasy Reactive's routing layer strips matrix parameters before matching endpoints. An attacker can append a semicolon and arbitrary text to a request URL (e.g., /api/admin;anything) to bypass policies protecting /api/admin while still routing to the protected endpoint. This issue has been fixed in versions 3.20.6.1, 3.27.3.1, 3.33.1.1, 3.35.1.1, 3.34.7, and 3.35.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.20.6.13.21.0 ≤ v < 3.27.3.13.28.0 ≤ v < 3.33.1.13.34.0 ≤ v < 3.34.73.35.0 ≤ v < 3.35.2
Affected range stops below 3.20.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.27.3.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.33.1.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.34.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.35.2, so it looks safe — our inference, not a vendor statement
v < 3.20.6.1v < 3.27.3.1v < 3.34.7v < 3.35.2
Affected range stops below 3.20.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.27.3.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.34.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.35.2, so it looks safe — our inference, not a vendor statement
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (11)

Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:11720
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:11721
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:13631
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17789
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:25089
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-39852
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2457819

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.2HIGHredhat-SADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863CWE-551

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card