CVE-2026-34573

Parse Server: GraphQL complexity validator exponential fragment traversal DoS

HIGH
7.5
CVSS Score
Published: March 31, 2026 at 03:06 PM UTC
Updated: July 24, 2026 at 08:20 PM UTC
2 products affected across 2 vendorsParse ServerParse Server

Using parse-server by parse-community?

Get instant alerts when new vulnerabilities affect parse-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.68 and 9.7.0-alpha.12, the GraphQL query complexity validator can be exploited to cause a denial-of-service by sending a crafted query with binary fan-out fragment spreads. A single unauthenticated request can block the Node.js event loop for seconds, denying service to all concurrent users. This only affects deployments that have enabled the requestComplexity.graphQLDepth or requestComplexity.graphQLFields configuration options. This issue has been patched in versions 8.6.68 and 9.7.0-alpha.12.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 8.6.68, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.7.0, so it looks safe — our inference, not a vendor statement
v < 8.6.68v < 9.7.0-alpha.12
Affected range stops below 8.6.68, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.7.0-alpha.12, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-407

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card