CVE-2026-34379

OpenEXR has a misaligned write in LossyDctDecoder_execute leading to undefined behavior (DWA/DWAB decompression)

HIGH
7.1
CVSS Score
Published: April 6, 2026 at 03:21 PM UTC
Updated: October 26, 2026 at 10:10 PM UTC
2 products affected across 2 vendorsOpenexrOpenexr

Using openexr by AcademySoftwareFoundation?

Get instant alerts when new vulnerabilities affect openexr - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a misaligned memory write vulnerability exists in LossyDctDecoder_execute() in src/lib/OpenEXRCore/internal_dwa_decoder.h:749. When decoding a DWA or DWAB-compressed EXR file containing a FLOAT-type channel, the decoder performs an in-place HALF→FLOAT conversion by casting an unaligned uint8_t * row pointer to float * and writing through it. Because the row buffer may not be 4-byte aligned, this constitutes undefined behavior under the C standard and crashes immediately on architectures that enforce alignment (ARM, RISC-V, etc.). On x86 it is silently tolerated at runtime but remains exploitable via compiler optimizations that assume aligned access. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.2.0 ≤ v < 3.2.73.3.0 ≤ v < 3.3.93.4.0 ≤ v < 3.4.9
Affected range stops below 3.2.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.4.9, so it looks safe — our inference, not a vendor statement
3.2.0 ≤ v < 3.2.73.3.0 ≤ v < 3.3.93.4.0 ≤ v < 3.4.9
Affected range stops below 3.2.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.4.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (7)

x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.7
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.9
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.9
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-34379
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2455402

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.1HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-704CWE-787CWE-843CWE-475

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card