CVE-2026-33331

oRPC: Stored XSS in OpenAPI Reference Plugin via unescaped JSON.stringify

MEDIUM
5.4
CVSS Score
Published: March 24, 2026 at 07:18 PM UTC
Updated: June 17, 2026 at 10:37 AM UTC
2 products affected across 2 vendorsOrpcOrpc

Using orpc by middleapi?

Get instant alerts when new vulnerabilities affect orpc - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

oRPC is an tool that helps build APIs that are end-to-end type-safe and adhere to OpenAPI standards. Prior to version 1.13.9, a stored cross-site scripting (XSS) vulnerability exists in the OpenAPI documentation generation of orpc. If an attacker can control any field within the OpenAPI specification (such as info.description), they can break out of the JSON context and execute arbitrary JavaScript when a user views the generated API documentation. This issue has been patched in version 1.13.9.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.13.9
Affected range stops below 1.13.9, so it looks safe — our inference, not a vendor statement
v < 1.13.9
Affected range stops below 1.13.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMExploitMitigationVendor Advisory
Source: cverecord
https://github.com/middleapi/orpc/security/advisories/GHSA-7f6v-3gx7-27q8
x_refsource_MISCProductRelease Notes
Source: cverecord
https://github.com/middleapi/orpc/releases/tag/v1.13.9

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card