CVE-2026-3304

Multer vulnerable to Denial of Service via incomplete cleanup

HIGH
7.5
CVSS Score
Published: February 27, 2026 at 03:44 PM UTC
Updated: July 15, 2026 at 02:20 AM UTC
2 products affected across 2 vendorsMulterSelf-Service Automation Portal

Using multer by expressjs?

Get instant alerts when new vulnerabilities affect multer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion. Users should upgrade to version 2.1.0 to receive a patch. No known workarounds are available.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.1.00.0.0 ≤ v < 2.1.00.0.0
Affected range stops below 2.1.0, so it looks safe — our inference, not a vendor statement

References (9)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHredhat-SADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-459

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card