CVE-2026-32721

LuCI luci-mod-network: Possible XSS attack in WiFi scan on Joining Wireless Client modal

MEDIUM
4.8
CVSS Score
Published: March 19, 2026 at 10:46 PM UTC
Updated: June 17, 2026 at 10:36 AM UTC
2 products affected across 1 vendorOpenWRTLuci

Using luci by openwrt?

Get instant alerts when new vulnerabilities affect luci - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

LuCI is the OpenWrt Configuration Interface. Versions prior to both 24.10.5 and 25.12.0, contain a stored XSS vulnerability in the wireless scan modal, where SSID values from scan results are rendered as raw HTML without any sanitization. The wireless.js file in the luci-mod-network package passes SSIDs via a template literal to dom.append(), which processes them through innerHTML, allowing an attacker to craft a malicious SSID containing arbitrary HTML/JavaScript. Exploitation requires the user to actively open the wireless scan modal (e.g., to connect to a Wi-Fi access point or survey nearby channels), and only affects OpenWrt versions newer than 23.05/22.03 up to the patched releases (24.10.6 and 25.12.1). The issue has been fixed in version LuCI 26.072.65753~068150b.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 26.072.65753v < 26.072.65753-068150b
Affected range stops below 26.072.65753, so it looks safe — our inference, not a vendor statement
v < 24.10.6v < 25.12.125.12.0 ≤ v < 25.12.1
Affected range stops below 24.10.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.12.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card