CVE-2026-28223

Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface

MEDIUM
6.1
CVSS Score
Published: March 5, 2026 at 06:56 PM UTC
Updated: June 17, 2026 at 10:28 AM UTC
2 products affected across 2 vendorsWagtailWagtail

Using wagtail by wagtail?

Get instant alerts when new vulnerabilities affect wagtail - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.3.86.4 ≤ v < 7.0.67.1 ≤ v < 7.2.37.37.3 rc1
v < 6.3.8v < 7.0.6v < 7.2.3v < 7.3.1
Affected range stops below 6.3.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.2.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.3.1, so it looks safe — our inference, not a vendor statement

References (9)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card