CVE-2026-26351

GetSimpleCMS-CE < 3.3.22 Stored XSS via components.php

MEDIUM
4.8
CVSS Score
Published: February 24, 2026 at 10:05 PM UTC
Updated: July 14, 2026 at 07:54 PM UTC
3 products affected across 3 vendorsGetsimple CMSGetsimple CMSGetSimpleCMS-CE

Using GetSimpleCMS-CE by GetSimpleCMS-CE?

Get instant alerts when new vulnerabilities affect GetSimpleCMS-CE - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

GetSimpleCMS Community Edition (CE) version 3.3.16 contains a stored cross-site scripting (XSS) vulnerability in the Theme to Components functionality within components.php. User-supplied input provided to the "slug" field of a component is stored without proper output encoding. While other fields are sanitized using safe_slash_html(), the slug parameter is written to XML and later rendered in the administrative interface without sanitation, resulting in persistent execution of arbitrary JavaScript. An authenticated administrator can inject malicious script content that executes whenever the affected Components page is viewed by any authenticated user, enabling session hijacking, unauthorized administrative actions, and persistent compromise of the CMS administrative interface.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.3.16 ≤ v < 3.3.22
Affected range stops below 3.3.22, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.3.22 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.8MEDIUMVulnCheck
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card