CVE-2026-2229

undici is vulnerable to Unhandled Exception in undici WebSocket Client Due to Invalid server_max_window_bits Validation

HIGH
7.5
CVSS Score
Published: March 12, 2026 at 08:27 PM UTC
Updated: September 4, 2026 at 01:18 PM UTC
7 products affected across 3 vendorsUndiciOpenShift AIOpenShift Pipelines

Using undici by undici?

Get instant alerts when new vulnerabilities affect undici - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

ImpactThe undici WebSocket client is vulnerable to a denial-of-service attack due to improper validation of the server_max_window_bits parameter in the permessage-deflate extension. When a WebSocket client connects to a server, it automatically advertises support for permessage-deflate compression. A malicious server can respond with an out-of-range server_max_window_bits value (outside zlib's valid range of 8-15). When the server subsequently sends a compressed frame, the client attempts to create a zlib InflateRaw instance with the invalid windowBits value, causing a synchronous RangeError exception that is not caught, resulting in immediate process termination. The vulnerability exists because: * The isValidClientWindowBits() function only validates that the value contains ASCII digits, not that it falls within the valid range 8-15 * The createInflateRaw() call is not wrapped in a try-catch block * The resulting exception propagates up through the call stack and crashes the Node.js process

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.24.07.0.0 ≤ v < 7.24.0
Affected range stops below 6.24.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.24.0, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 1776784286 (unaffected)
Vendor states this is fixed in 1777903262 (unaffected)
All versions
Vendor states this is fixed in 1774282136 (unaffected)
All versions
Vendor states this is fixed in 1779910201 (unaffected)
v < 6.24.0
Affected range stops below 6.24.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.24.0: 7.24.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (24)

Permissions Required
Source: cverecord
https://hackerone.com/reports/3487486
Vendor Advisory
Source: cverecord
https://cna.openjsf.org/security-advisories.html
Technical Description
Source: cverecord
https://datatracker.ietf.org/doc/html/rfc7692
Technical Description
Source: cverecord
https://nodejs.org/api/zlib.html#class-zlibinflateraw
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:13826
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17789
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:21772

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-248CWE-1284

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card