CVE-2026-19633

PostgreSQL Anonymizer: unprivileged masked users can execute code via operators, domain casts and view subqueries

HIGH
8.8
CVSS Score
Published: September 6, 2026 at 03:25 PM UTC
Updated: September 9, 2026 at 05:17 AM UTC
1 product affected across 1 vendorPostgreSQL Anonymizer

Using PostgreSQL Anonymizer by DALIBO?

Get instant alerts when new vulnerabilities affect PostgreSQL Anonymizer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the malicious code can run with elevated privileges. The issue is fixed in PostgreSQL Anonymizer 3.1.4 and later versions

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1 ≤ v < 3.1.41
Affected range stops below 3.1.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHPostgreSQL
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-89

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card