CVE-2026-19589

Packer vulnerable to arbitrary file write via crafted plugin archive during installation

HIGH
7.1
CVSS Score
Published: August 17, 2026 at 08:22 PM UTC
Updated: October 23, 2026 at 04:10 PM UTC
1 product affected across 1 vendorPacker

Using Packer by HashiCorp?

Get instant alerts when new vulnerabilities affect Packer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Packer up to 1.15.4 is vulnerable to an issue in the third-party plugin installer that may allow unintended file system modification and could lead to code execution. A user who installs a plugin from a malicious or compromised source may be affected. This vulnerability (CVE-2026-19589) is fixed in Packer 1.16.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.7.0 ≤ v < 1.16.01.7.0
Affected range stops below 1.16.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.1HIGHHashiCorp
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card