CVE-2026-19032

jackson-databind resolves attacker-controlled URI schemes when deserializing java.nio.file.Path

MEDIUM
5.3
CVSS Score
Published: September 1, 2026 at 03:18 AM UTC
Updated: September 8, 2026 at 07:29 PM UTC
1 product affected across 1 vendorJackson Databind

Using jackson-databind by FasterXML?

Get instant alerts when new vulnerabilities affect jackson-databind - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.6%
SSVC
PoC

Description

jackson-databind's deserializer for java.nio.file.Path resolves an attacker-supplied URI without restricting the URI scheme. In JDKFromStringDeserializer.NioPathHelper.deserialize, a string bound from untrusted JSON is passed to new URI(value) and then to Path.of(uri). When that throws FileSystemNotFoundException, the code enumerates ServiceLoader<FileSystemProvider> and calls provider.getPath(uri) on the first provider whose scheme matches the attacker-chosen scheme. Untrusted JSON can therefore select and drive an arbitrary registered FileSystemProvider during readValue under a default JsonMapper, and forces provider class loading at the same time. With only the JDK built-in providers (file, jar/zipfs) present, the resolved path is inert and no mount or network I/O occurs; further impact requires a side-effecting third-party FileSystemProvider on the classpath. This affects com.fasterxml.jackson.core:jackson-databind from 2.8.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2. Binding java.nio.file.Path from untrusted JSON should be avoided regardless of version.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.19.0 ≤ v < 2.21.62.22.0 ≤ v < 2.22.22.8.0 ≤ v < 2.18.103.0.0 ≤ v < 3.1.63.2.0 ≤ v < 3.2.22.19.02.22.02.8.03.0.03.2.0
Affected range stops below 2.18.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.21.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.22.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.2, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMHeroDevs
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-470CWE-610

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card