CVE-2026-18540

undici vulnerable to downstream response splitting via retry interceptor

LOW
3.7
CVSS Score
Published: September 4, 2026 at 05:15 PM UTC
Updated: September 16, 2026 at 08:54 PM UTC
2 products affected across 2 vendorsUndiciUndici

Using undici by undici?

Get instant alerts when new vulnerabilities affect undici - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.7
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume checkpoint, for example a non-success response whose headers were already sent or a partial-content response with an unusable content range, then closes the connection and answers the resumed range request with more bytes. As a result the response body can be longer than the Content-Length that the application observes. An application that relays such a response to a downstream HTTP/1.1 peer without normalizing the framing can emit a body that exceeds the forwarded Content-Length, and the excess bytes can be interpreted as the start of a following response, which enables downstream response splitting or desynchronization. Exploitation requires an attacker-controlled upstream server and an application that forwards the response through a framing-sensitive path. This affects undici versions before 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.28.17.0.0 ≤ v < 7.29.18.0.0 ≤ v < 8.10.2
Affected range stops below 6.28.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.29.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.10.2, so it looks safe — our inference, not a vendor statement
v < 6.28.17.0.0 ≤ v < 7.29.18.0.0 ≤ v < 8.10.27.0.08.0.0
Vendor states this is fixed in 6.28.1 (unaffected)
Vendor states this is fixed in 7.29.1 (unaffected)
Vendor states this is fixed in 8.10.2 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.7LOWopenjs
Vector?

Quick Info

StatusANALYZED
CWE
CWE-444

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card