CVE-2026-18394

Incorrect authorization in Strands Agents Tools http_request proxy credential exfiltration

HIGH
7.4
CVSS Score
Published: July 31, 2026 at 07:34 PM UTC
Updated: October 23, 2026 at 11:10 PM UTC
1 product affected across 1 vendorStrands Agents Tools

Using Strands Agents Tools by AWS?

Get instant alerts when new vulnerabilities affect Strands Agents Tools - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.4
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Incorrect authorization in the http_request tool in Strands Agents Tools before 0.8.2 might allow remote attackers to obtain credentials configured via HTTP_REQUEST_TOKEN_CONFIG by influencing the LLM to route requests through actor-controlled proxy infrastructure. To remediate this issue, users should upgrade to version 0.8.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0 ≤ v < 0.8.20
Affected range stops below 0.8.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.4HIGHAMZN
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card