CVE-2026-1526

undici is vulnerable to Unbounded Memory Consumption in undici WebSocket permessage-deflate Decompression

HIGH
7.5
CVSS Score
Published: March 12, 2026 at 08:08 PM UTC
Updated: September 4, 2026 at 01:18 PM UTC
8 products affected across 3 vendorsUndiciOpenShift AIOpenShift Pipelines

Using undici by undici?

Get instant alerts when new vulnerabilities affect undici - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

The undici WebSocket client is vulnerable to a denial-of-service attack via unbounded memory consumption during permessage-deflate decompression. When a WebSocket connection negotiates the permessage-deflate extension, the client decompresses incoming compressed frames without enforcing any limit on the decompressed data size. A malicious WebSocket server can send a small compressed frame (a "decompression bomb") that expands to an extremely large size in memory, causing the Node.js process to exhaust available memory and crash or become unresponsive. The vulnerability exists in the PerMessageDeflate.decompress() method, which accumulates all decompressed chunks in memory and concatenates them into a single Buffer without checking whether the total size exceeds a safe threshold.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.24.07.0.0 ≤ v < 7.24.0
Affected range stops below 6.24.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.24.0, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 1776784286 (unaffected)
Vendor states this is fixed in 1777903262 (unaffected)
All versions
Vendor states this is fixed in 1774282136 (unaffected)
All versions
Vendor states this is fixed in 1779814592 (unaffected)
All versions
Vendor states this is fixed in 1779910201 (unaffected)
v < 6.24.0
Affected range stops below 6.24.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.24.0: 7.24.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (23)

Permissions Required
Source: cverecord
https://hackerone.com/reports/3481206
Vendor Advisory
Source: cverecord
https://cna.openjsf.org/security-advisories.html
Technical Description
Source: cverecord
https://datatracker.ietf.org/doc/html/rfc7692
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:13826
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:17789
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:21772
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:21931

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-409CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card