CVE-2026-14340

An incorrect authorization vulnerability in GitHub Enterprise Server allows issue creation in unrelated public repositories

MEDIUM
5
CVSS Score
Published: July 1, 2026 at 09:03 PM UTC
Updated: October 25, 2026 at 04:10 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a user-to-server token scoped to a GitHub App installation to perform certain write operations on public repositories outside the token's intended scope. This was possible because the authorization check only verified that the installation had read permissions on the target repository rather than verifying that the token's installation was explicitly granted access to that repository. An attacker who obtained a victim's user-to-server token could create issues, issue comments, commit comments, and private vulnerability reports on any public repository, appearing as the victim user with no indication of the app involvement. This vulnerability was fixed by adding a repository scope check for user-to-server tokens issued by global apps. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.21.2, 3.20.4, 3.19.8, 3.18.11, 3.17.17, 3.16.20. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.16.203.17.0 ≤ v < 3.17.173.18.0 ≤ v < 3.18.113.19.0 ≤ v < 3.19.83.20.0 ≤ v < 3.20.43.21.0 ≤ v < 3.21.23.16.03.17.03.18.03.19.03.20.03.21.0
Affected range stops below 3.16.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card