CVE-2026-117614

HIGH
7.2
CVSS Score
Published: October 28, 2026 at 04:48 PM UTC
Updated: November 2, 2026 at 03:22 PM UTC
1 product affected across 1 vendorJenkins

Using Jenkins by Jenkins Project?

Get instant alerts when new vulnerabilities affect Jenkins - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.4%

Description

Jenkins 2.587 and earlier, LTS 2.580.1 and earlier converts the launch commands in older agent configurations into launchers provided by the Command Agent Launcher Plugin without checking whether they have been approved by an administrator, allowing attackers with Agent/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Jenkins· Jenkinsjenkins-plugin
95%
v < 2.580.2v < 2.588
Vendor states this is fixed in 2.580.2 (unaffected)
Vendor states this is fixed in 2.588 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card