CVE-2026-116178

vLLM 0.20.0 before 0.30.0 DoS via /inference/v1/generate mm_placeholders

HIGH
7.5
CVSS Score
Published: October 25, 2026 at 01:20 PM UTC
Updated: October 28, 2026 at 03:40 PM UTC
1 product affected across 1 vendorvLLM

Using vllm by vllm-project?

Get instant alerts when new vulnerabilities affect vllm - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. Attackers can replay a valid multimodal item with repeated or overlapping mm_placeholders ranges or mismatched kwargs_data and mm_hashes lists, producing a negative text span in Qwen2.5-VL position construction that terminates the engine.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.20.0 ≤ v < 0.30.0
Vendor states this is fixed in 0.30.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card