CVE-2026-116172

vLLM 0.22.0 before 0.24.0 DoS via Rust gRPC CandidateTokens.top_n

HIGH
7.5
CVSS Score
Published: October 25, 2026 at 01:20 PM UTC
Updated: October 28, 2026 at 03:43 PM UTC
1 product affected across 1 vendorvLLM

Using vllm by vllm-project?

Get instant alerts when new vulnerabilities affect vllm - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.3%

Description

vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC converter that allows remote attackers to bypass max_logprobs limits via CandidateTokens.top_n. Attackers can send Generate or GenerateStream requests with oversized or integer-wrapping top_n values to trigger torch.topk failures that terminate EngineCore.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.22.0 ≤ v < 0.24.0
Vendor states this is fixed in 0.24.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card