CVE-2026-11440

theonedev REST API default-branch improper authorization

MEDIUM
6.3
CVSS Score
Published: June 6, 2026 at 05:30 PM UTC
Updated: July 23, 2026 at 07:35 AM UTC
1 product affected across 1 vendorProject Onedev

Using onedev by theonedev?

Get instant alerts when new vulnerabilities affect onedev - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 15.0.6 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (6)

VDB EntryTechnical Description
Source: cverecord
https://vuldb.com/vuln/369020
SignaturePermissions Required
Source: cverecord
https://vuldb.com/vuln/369020/cti
Third Party Advisory
Source: cverecord
https://vuldb.com/cve/CVE-2026-11440
Third Party Advisory
Source: cverecord
https://vuldb.com/submit/822956

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMVulDB
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-285CWE-266

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card