CVE-2026-104872

Multiple @opentelemetry/instrumentation-* packages expose database username via unconditional db.user span attribute

MEDIUM
5.8
CVSS Score
Published: October 2, 2026 at 07:50 PM UTC
Updated: October 6, 2026 at 05:17 PM UTC
9 products affected across 1 vendorInstrumentation Cassandra DriverInstrumentation TediousInstrumentation Pg

Using opentelemetry-js-contrib by open-telemetry?

Get instant alerts when new vulnerabilities affect opentelemetry-js-contrib - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

OpenTelemetry JavaScript Contrib provides instrumentation libraries for collecting telemetry from JavaScript applications. Prior to versions 0.66.0 of @opentelemetry/instrumentation-cassandra-driver, 0.65.0 of @opentelemetry/instrumentation-knex, 0.67.0 of @opentelemetry/instrumentation-mongoose, @opentelemetry/instrumentation-mysql, and @opentelemetry/instrumentation-mysql2, 0.46.0 of @opentelemetry/instrumentation-oracledb, 0.73.0 of @opentelemetry/instrumentation-pg, and 0.40.0 of @opentelemetry/instrumentation-tedious, the packages add the database connection username to every instrumented database operation as the db.user span attribute. The attribute is emitted by default and is not controlled by enhancedDatabaseReporting or another opt-in setting. Configured observability backends therefore receive database account names that may expose service topology, role or environment information, and account naming patterns. This issue is fixed in versions 0.66.0, 0.65.0, 0.67.0, 0.46.0, 0.73.0, and 0.40.0 of the respective packages.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.66.0
Affected range stops below 0.66.0, so it looks safe — our inference, not a vendor statement
v < 0.65.0
Affected range stops below 0.65.0, so it looks safe — our inference, not a vendor statement
v < 0.67.0
Affected range stops below 0.67.0, so it looks safe — our inference, not a vendor statement
v < 0.67.0
Affected range stops below 0.67.0, so it looks safe — our inference, not a vendor statement
v < 0.67.0
Affected range stops below 0.67.0, so it looks safe — our inference, not a vendor statement
v < 0.46.0
Affected range stops below 0.46.0, so it looks safe — our inference, not a vendor statement
v < 0.73.0
Affected range stops below 0.73.0, so it looks safe — our inference, not a vendor statement
v < 0.40.0
Affected range stops below 0.40.0, so it looks safe — our inference, not a vendor statement
v < 27e172a9e0d549559056ccd58f27d13467454156

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.8MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-532

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card