CVE-2026-104474

OpenLiteSpeed before 1.9.3 Local Privilege Escalation via lsup.sh Auto-Update

MEDIUM
6.7
CVSS Score
Published: October 2, 2026 at 11:28 PM UTC
Updated: October 6, 2026 at 04:08 PM UTC
1 product affected across 1 vendorOpenlitespeed

Using openlitespeed by litespeedtech?

Get instant alerts when new vulnerabilities affect openlitespeed - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.7
Exploit prediction
EPSS 0.1%
SSVC
No known exploit

Description

OpenLiteSpeed before 1.9.3 contains a local privilege escalation vulnerability in admin/misc/lsup.sh that runs unverified update packages from a nobody-writable directory as root. Attackers controlling the nobody web process can replace the package in /usr/local/lsws/autoupdate/ before extraction, so its install.sh runs as root on the next update.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.9.3
Vendor states this is fixed in 1.9.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.7MEDIUMVulnCheck
Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-367

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card