CVE-2026-104431

Zebra before 6.0.0 Denial of Service via Synchronous Script FFI Verification

HIGH
7.5
CVSS Score
Published: October 2, 2026 at 11:38 AM UTC
Updated: October 2, 2026 at 05:59 PM UTC
2 products affected across 2 vendorsZebraZebra

Using zebra by ZcashFoundation?

Get instant alerts when new vulnerabilities affect zebra - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Zebra before 6.0.0 contains a denial of service vulnerability that allows unauthenticated peers to stall Tokio workers by submitting mempool transactions requiring expensive synchronous script verification. Attackers can send non-standard high-sigop P2SH transactions that reach CachedFfiTransaction::is_valid() before standardness checks, saturating the verifier buffer and rendering the node unresponsive.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 6.0.0
Affected range stops below 6.0.0, so it looks safe — our inference, not a vendor statement
v < 6.0.0
Vendor states this is fixed in 6.0.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-405

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card