CVE-2026-103552

Apache Directory LDAP API: A unbound client can send a deeply nested search filter that overflows the stack in the server's decoder

HIGH
7.3
CVSS Score
Published: October 2, 2026 at 09:48 AM UTC
Updated: October 2, 2026 at 10:16 PM UTC
1 product affected across 1 vendorDirectory LDAP API

Using Apache Directory LDAP API by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Directory LDAP API - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.2.0 ≤ v < 1.2.91.2.0
Affected range stops below 1.2.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.3HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-121

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card