CVE-2026-101042

Parse Server 9.0.0 Authentication Bypass via Unverified Provider Identity

MEDIUM
6.4
CVSS Score
Published: September 27, 2026 at 04:28 PM UTC
Updated: September 30, 2026 at 05:23 PM UTC
2 products affected across 2 vendorsParse ServerParse Server

Using parse-server by parse-community?

Get instant alerts when new vulnerabilities affect parse-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.4
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Parse Server is an open-source backend server. In versions >= 9.0.0 < 9.10.1-alpha.10 and >= 8.0.2 < 8.6.91, the code-based authentication adapters (GitHub, Google Play Games, Instagram, LINE, LinkedIn, Microsoft, QQ, Spotify, WeChat, Weibo) verify the client's authorization code with the external provider on signup and on provider linking, but not when authentication data is supplied together with a username and password on the login endpoint. As a result, a low-privileged authenticated user can attach an arbitrary, unverified provider identity to their own account without the provider ever being contacted, spoofing an external identity toward application logic that trusts the linked provider ID. An attacker can also pre-hijack accounts: by claiming the provider ID of a victim who has not yet linked that provider, the victim's later legitimate sign-in with that provider resolves to the attacker's account. Only deployments configuring one of the affected code-based auth adapters are impacted. Versions 9.10.1-alpha.10 and 8.6.91 fix the issue by running the adapter's credential verification on the login and challenge endpoints and rejecting a provider identity already linked to another user. As a workaround, disable the affected code-based auth adapters.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

8.0.2 ≤ v < 8.6.919.0.0 ≤ v < 9.10.1-alpha.10
Affected range stops below 8.6.91, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.10.1-alpha.10, so it looks safe — our inference, not a vendor statement
8.0.2 ≤ v < 8.6.919.0.0 ≤ v < 9.10.1-alpha.108.0.29.0.0
Vendor states this is fixed in 8.6.91 (unaffected)
Vendor states this is fixed in 9.10.1-alpha.10 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.4MEDIUMVulnCheck
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card