CVE-2025-8591

Reflected Cross-Site Scripting via URL Parameter in Multiple WSO2 Products Enables UI Modification

MEDIUM
6.1
CVSS Score
Published: July 6, 2026 at 10:16 AM UTC
Updated: October 6, 2026 at 10:10 PM UTC
8 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Identity Server by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Identity Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

The software accepts user-supplied input via a URL parameter without adequate output encoding before reflecting it back to the user's browser. This condition allows an attacker to inject malicious script content into pages served by the application. By leveraging this weakness, an attacker can cause the user's browser to redirect to a malicious website, modify the UI of the webpage, or retrieve information from the browser. However, the impact is mitigated by the use of httpOnly flags on session-related cookies, preventing session hijacking.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.444.6.0 ≤ v < 4.6.0.84.5.04.6.0
Affected range stops below 4.5.0.44, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.8, so it looks safe — our inference, not a vendor statement
3.1.0 ≤ v < 3.1.0.3553.2.0 ≤ v < 3.2.0.4593.2.1 ≤ v < 3.2.1.784.0.0 ≤ v < 4.0.0.3804.1.0 ≤ v < 4.1.0.2434.2.0 ≤ v < 4.2.0.1834.3.0 ≤ v < 4.3.0.944.4.0 ≤ v < 4.4.0.584.5.0 ≤ v < 4.5.0.434.6.0 ≤ v < 4.6.0.73.1.03.2.03.2.14.0.04.1.04.2.04.3.04.4.04.5.04.6.0
Affected range stops below 3.1.0.355, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.459, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.78, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.380, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.243, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.183, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.94, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.58, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.43, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
5.10.0 ≤ v < 5.10.0.3815.10.0 ≤ v < 5.10.0.3846.0.0 ≤ v < 6.0.0.2557.0.0 ≤ v < 7.0.0.1317.1.0 ≤ v < 7.1.0.217.1.0 ≤ v < 7.1.0.515.10.06.0.07.0.07.1.0
Affected range stops below 5.10.0.381, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.10.0.384, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.255, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.131, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.51, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3755.10.0
Affected range stops below 5.10.0.375, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
2.0.0 ≤ v < 2.0.0.4042.0.0
Affected range stops below 2.0.0.404, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
2.0.0 ≤ v < 2.0.0.4242.0.0
Affected range stops below 2.0.0.424, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.424.6.0 ≤ v < 4.6.0.74.5.04.6.0
Affected range stops below 4.5.0.42, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.7, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.424.6.0 ≤ v < 4.6.0.74.5.04.6.0
Affected range stops below 4.5.0.42, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMWSO2
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card