CVE-2025-8325

Improper Access Control via Gateway API in Multiple WSO2 Products Allows Unauthorized Operations

HIGH
8.8
CVSS Score
Published: May 11, 2026 at 09:37 AM UTC
Updated: October 14, 2026 at 01:10 PM UTC
6 products affected across 1 vendorAPI ManagerAPI Control PlaneTraffic Manager

Using WSO2 API Control Plane by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 API Control Plane - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

The software fails to enforce role-based access controls for certain Gateway API invocations. Users with the 'Internal/Everyone' role can invoke these APIs, bypassing intended permission checks. This same vulnerability also affects Internal Service APIs, potentially exposing them in WSO2 APIM 3.x versions. A malicious actor with a valid user account on a vulnerable deployment can perform sensitive operations against the Gateway REST API regardless of their actual roles or privileges. This could lead to unintended behavior or misuse, particularly in production environments.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.184.5.0
Affected range stops below 4.5.0.18, so it looks safe — our inference, not a vendor statement
3.2.0 ≤ v < 3.2.0.4353.2.1 ≤ v < 3.2.1.554.0.0 ≤ v < 4.0.0.3554.1.0 ≤ v < 4.1.0.2194.2.0 ≤ v < 4.2.0.1574.3.0 ≤ v < 4.3.0.704.4.0 ≤ v < 4.4.0.334.5.0 ≤ v < 4.5.0.173.2.03.2.14.0.04.1.04.2.04.3.04.4.04.5.0
Affected range stops below 3.2.0.435, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.355, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.219, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.157, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.70, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.17, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.2.0 (unknown)
4.5.0 ≤ v < 4.5.0.174.5.0
Affected range stops below 4.5.0.17, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.174.5.0
Affected range stops below 4.5.0.17, so it looks safe — our inference, not a vendor statement
6.7.206 ≤ v < 6.7.206.5636.7.210 ≤ v < 6.7.210.559.0.174 ≤ v < 9.0.174.5139.20.74 ≤ v < 9.20.74.3759.28.116 ≤ v < 9.28.116.3529.29.120 ≤ v < 9.29.120.1779.30.67 ≤ v < 9.30.67.1009.31.86 ≤ v < 9.31.86.586.7.2066.7.2109.0.1749.20.749.28.1169.29.1209.30.679.31.86
Affected range stops below 6.7.206.563, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7.210.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.174.513, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.20.74.375, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.28.116.352, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.29.120.177, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.30.67.100, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.31.86.58, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.32.75 (unaffected)
6.7.206 ≤ v < 6.7.206.5636.7.210 ≤ v < 6.7.210.559.0.174 ≤ v < 9.0.174.5139.20.74 ≤ v < 9.20.74.3759.28.116 ≤ v < 9.28.116.3529.29.120 ≤ v < 9.29.120.1779.30.67 ≤ v < 9.30.67.1009.31.86 ≤ v < 9.31.86.586.7.2066.7.2109.0.1749.20.749.28.1169.29.1209.30.679.31.86
Affected range stops below 6.7.206.563, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.7.210.55, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.174.513, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.20.74.375, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.28.116.352, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.29.120.177, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.30.67.100, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.31.86.58, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.32.75 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-281

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card