CVE-2025-6670

Cross-Site Request Forgery (CSRF) in Multiple WSO2 Products via HTTP GET in Admin Services

HIGH
8.8
CVSS Score
Published: November 18, 2025 at 11:28 AM UTC
Updated: June 17, 2026 at 10:02 AM UTC
10 products affected across 1 vendorAPI ManagerIdentity ServerIdentity Server As Key Manager

Using WSO2 Open Banking AM by WSO2?

Get instant alerts when new vulnerabilities affect WSO2 Open Banking AM - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in multiple WSO2 products due to the use of the HTTP GET method for state-changing operations within admin services, specifically in the event processor of the Carbon console. Although the SameSite=Lax cookie attribute is used as a mitigation, it is ineffective in this context because it allows cookies to be sent with cross-origin top-level navigations using GET requests. A malicious actor can exploit this vulnerability by tricking an authenticated user into visiting a crafted link, leading the browser to issue unintended state-changing requests. Successful exploitation could result in unauthorized operations such as data modification, account changes, or other administrative actions. According to WSO2 Secure Production Guidelines, exposure of Carbon console services to untrusted networks is discouraged, which may reduce the impact in properly secured deployments.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.5.0 ≤ v < 4.5.0.364.6.0 ≤ v < 4.6.0.14.5.04.6.0
Affected range stops below 4.5.0.36, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.1, so it looks safe — our inference, not a vendor statement
3.1.0 ≤ v < 3.1.0.3493.2.0 ≤ v < 3.2.0.4533.2.1 ≤ v < 3.2.1.734.0.0 ≤ v < 4.0.0.3734.1.0 ≤ v < 4.1.0.2364.2.0 ≤ v < 4.2.0.1764.3.0 ≤ v < 4.3.0.884.4.0 ≤ v < 4.4.0.524.5.0 ≤ v < 4.5.0.354.6.0 ≤ v < 4.6.0.13.1.03.2.03.2.14.0.04.1.04.2.04.3.04.4.04.5.04.6.0
Affected range stops below 3.1.0.349, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.0.453, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.1.73, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.0.373, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.0.236, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.0.176, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.0.88, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.0.52, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.0.35, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.1.0 (unknown)
6.6.0 ≤ v < 6.6.0.2266.6.0
Affected range stops below 6.6.0.226, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.6.0 (unknown)
5.10.0 ≤ v < 5.10.0.3785.11.0 ≤ v < 5.11.0.4256.0.0 ≤ v < 6.0.0.2526.1.0 ≤ v < 6.1.0.2537.0.0 ≤ v < 7.0.0.1307.1.0 ≤ v < 7.1.0.387.2.0 ≤ v < 7.2.0.15.10.05.11.06.0.06.1.07.0.07.1.07.2.0
Affected range stops below 5.10.0.378, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.11.0.425, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.0.252, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.0.253, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.0.130, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0.38, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.2.0.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
5.10.0 ≤ v < 5.10.0.3695.10.0
Affected range stops below 5.10.0.369, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.0 (unknown)
Vendor states this is fixed in 2.0.0 (unaffected)
Vendor states this is fixed in 2.0.0 (unknown)
Vendor states this is fixed in 2.0.0 (unaffected)
Vendor states this is fixed in 2.0.0 (unknown)
4.5.0 ≤ v < 4.5.0.344.6.0 ≤ v < 4.6.0.14.5.04.6.0
Affected range stops below 4.5.0.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.1, so it looks safe — our inference, not a vendor statement
4.5.0 ≤ v < 4.5.0.344.6.0 ≤ v < 4.6.0.14.5.04.6.0
Affected range stops below 4.5.0.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.1, so it looks safe — our inference, not a vendor statement
4.10.101 ≤ v < 4.10.101.34.10.42 ≤ v < 4.10.42.184.10.9 ≤ v < 4.10.9.754.5.3 ≤ v < 4.5.3.504.6.0 ≤ v < 4.6.0.22534.6.1 ≤ v < 4.6.1.1574.6.2 ≤ v < 4.6.2.6734.6.3 ≤ v < 4.6.3.414.6.4 ≤ v < 4.6.4.224.7.1 ≤ v < 4.7.1.734.8.1 ≤ v < 4.8.1.434.9.0 ≤ v < 4.9.0.1064.9.26 ≤ v < 4.9.26.314.9.27 ≤ v < 4.9.27.164.9.28 ≤ v < 4.9.28.184.9.33 ≤ v < 4.9.33.24.10.1014.10.424.10.94.5.34.6.04.6.14.6.24.6.34.6.44.7.14.8.14.9.04.9.264.9.274.9.284.9.33
Affected range stops below 4.10.101.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.10.42.18, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.10.65 (unaffected)
Affected range stops below 4.10.9.75, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.3.50, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.0.2253, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.1.157, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.2.673, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.3.41, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.4.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.1.73, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.1.43, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.0.106, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.26.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.27.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.28.18, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.9.29 (unaffected)
Affected range stops below 4.9.33.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHWSO2
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card