CVE-2025-66675

Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed

HIGH
8.2
CVSS Score
Published: December 10, 2025 at 09:32 AM UTC
Updated: October 14, 2026 at 09:10 PM UTC
1 product affected across 1 vendorStruts

Using Apache Struts by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Struts - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.2
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue. It's related to  https://cve.org/CVERecord?id=CVE-2025-64775  - this CVE addresses missing affected version 6.7.4

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions2.0.0 ≤ v ≤ 2.3.372.5.0 ≤ v ≤ 2.5.336.0.0 ≤ v < 6.8.07.0.0 ≤ v < 7.1.12.0.07.0.0

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

RelatedThird Party Advisory
Source: cverecord
https://cve.org/CVERecord?id=CVE-2025-64775

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.2HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-459

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card