CVE-2025-66459

Lookyloo vulnerable to XSS due to unescaped error message passed to innerHTML

MEDIUM
6.1
CVSS Score
Published: December 2, 2025 at 06:32 PM UTC
Updated: September 25, 2026 at 11:27 PM UTC
1 product affected across 1 vendorLookyloo

Using lookyloo by Lookyloo?

Get instant alerts when new vulnerabilities affect lookyloo - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, a XSS vulnerability can be triggered when a user submits a list of URLs to capture, one of them contains a HTML element, and the capture fails. Then, the error field is populated with an error message that contains the bad URL they tried to capture, triggering the XSS. This vulnerability is fixed in 1.35.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.35.3
Affected range stops below 1.35.3, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card